157个红队目标打点漏洞,95%严重高危,有POC、有修复方案的送分题千万别丢!
2024-6-21 19:57:55 Author: mp.weixin.qq.com(查看原文) 阅读量:15 收藏

攻防演练最新漏洞合集:100%有POC,95%严重高危,企业几乎都在用,速查速修!

收敛攻击面绝佳指南,攻防演练必备

01

前言

2024年网络安全攻防演练即将拉开帷幕,360漏洞云情报订阅服务平台沉淀数年实战经验,分析总结近年演练中爆发的易受攻击的漏洞,梳理出《2024 攻防演练必修高危漏洞合集》,针对性地提供漏洞排查工具和解决方案,帮助企业提前发现安全隐患,有效降低攻击风险,收敛攻击面。

本次报告包含的漏洞绝大多数为严重、高危,涉及大多数企业在用的办公类软件和系统组件,所有漏洞都经过漏洞云高级情报专家研判分析,100%有POC,100%提供修复方案,请各位师傅速自查自修,决胜演练前夜!

02

整体概述

危害等级分析:严重和高危漏洞占比为95%,剩余5%虽是中危漏洞,但在实战中极易受攻击并造成重大危害。

漏洞危害等级分布

漏洞类型分析:重点聚焦资源控制不当、中和不当和访问控制不当。

漏洞类型分布

从漏洞类型分布来看,中和不当占比最高,这种漏洞是由于程序从上游组件读取的消息发送到下游组件之前,未中和或不正确地中和可能被解释为控制元素或语法标记的特殊元素,导致远程任意命令执行(RACE)、远程任意代码执行(RACE)、GetShell、权限提升、信息泄露、敏感信息泄露、系统崩溃或重启、功能失控等安全问题。其次是资源控制不当,程序在资源(资源可能为:内存空间、数据、变量、对象、文件、指针等等)的创建、使用、发布和传输的整个生命周期中未维持或错误地维持对资源的控制,导致信息泄露、资源消耗、系统崩溃或重启、拒绝服务、远程任意命令执行(RACE)、远程任意代码执行(RACE)等安全问题。

产品分布分析:企业自动化办公系统、项目管理软件、企业资源计划系统、网络安全产品和软件开发框架为漏洞的重灾区。

漏洞产品分布

以产品来看,出现漏洞最多的产品类型为自动化办公系统(OA系统),自动化办公系统(OA系统)在现代企业中扮演着至关重要的角色,它们简化了工作流程,增强了协作能力,并提高了整体生产力。但由于在开发中对研发人员对输入验证不足,不正确实现的API和缺乏API访问控制等原因,造成自动化办公系统(OA系统)是历年攻防演练的重灾区,相关用户应重点防范。此外爆发出现较多的项目管理系统和企业资源计划系统漏洞,用户也值得关注。

03

综合评分9.8以上漏洞TOP11

以下内容为2024攻防演练必修关键漏洞部分内容,漏洞云情报订阅用户可登录漏洞云情报平台,获取更多漏洞检测和修复方案。

Atlassian Confluence Data Center 权限管理不当

内部编号

LDYVUL-2023-00523641

漏洞等级

严重

漏洞类型

权限管理不当

披露时间

2023-10-11

漏洞概述:

Atlassian Confluence Server是澳大利亚Atlassian公司的一套具有企业知识管理功能,并支持用于构建企业WiKi的协同软件的服务器版本。

Atlassian Confluence Server存在安全漏洞,该漏洞源于外部攻击者可能利用可公开访问的Confluence Data Center和Confluence Serve,用未知的漏洞来创建Confluence 管理员帐户并访问 Confluence 实例。

影响范围:

8.4.0<=Atlassian Confluence<8.4.3

8.5.0<=Atlassian Confluence<8.5.2

8.0.0<=Atlassian Confluence<8.3.3

修复建议:

针对此安全漏洞,官方已发布了一个修复补丁。请立即访问链接 [https://confluence.atlassian.com/pages/viewpage.action?pageId=1295682276] 进行下载和安装。此补丁旨在解决特定的安全问题,确保系统的安全性和稳定性。安装前,请确保备份所有关键数据,并按照官方指南进行操作。安装后,进行全面测试以验证漏洞已被彻底修复,并确保系统其他功能正常运行。

Apache Activemq 未授权 反序列化

内部编号

LDYVUL-2023-00684448

漏洞等级

严重

漏洞类型

反序列化

披露时间

2023-10-25

漏洞概述:

Apache ActiveMQ是美国阿帕奇(Apache)基金会的一套开源的消息中间件,它支持Java消息服务、集群、Spring Framework等。ActiveMQ 5.15.16之前、5.16.7之前、5.17.6之前或5.18.3之前版本存在反序列化漏洞,该漏洞允许远程攻击者通过向Apache ActiveMQ的61616端口发送特制的恶意数据,导致在目标系统上执行任意代码。

影响范围:

5.17.0<=Apache ActiveMQ<5.17.6

5.18.0<=Apache ActiveMQ<5.18.3

Apache ActiveMQ<5.15.16

5.16.0<=Apache ActiveMQ<5.16.7

修复建议:

针对此安全漏洞,官方已发布了一个修复补丁。请立即访问链接 [https://activemq.apache.org/] 进行下载和安装。此补丁旨在解决特定的安全问题,确保系统的安全性和稳定性。安装前,请确保备份所有关键数据,并按照官方指南进行操作。安装后,进行全面测试以验证漏洞已被彻底修复,并确保系统其他功能正常运行。

Gitlab 访问控制不当 可致密码重置(CVE-2023-7028)

内部编号

LDYVUL-2024-00003169

漏洞等级

严重

漏洞类型

访问控制不当

披露时间

2023-12-20

漏洞概述:

GitLab是美国GitLab公司的一个开源的端到端软件开发平台,具有内置的版本控制、问题跟踪、代码审查、CI/CD(持续集成和持续交付)等功能。

GitLab 存在安全漏洞,该漏洞源于用户帐户密码重置电子邮件可能会发送到未经验证的电子邮件地址。

影响范围:

16.2.0<=GitLab<16.2.9

16.3.0<=GitLab<16.3.7

16.4.0<=GitLab<16.4.5

16.5.0<=GitLab<16.5.6

16.6.0<=GitLab<16.6.4

16.7.0<=GitLab<16.7.2

16.1.0<=GitLab<16.1.6

修复建议:

针对此安全漏洞,官方已发布了一个修复补丁。请立即访问链接 [https://gitlab.com/gitlab-org/gitlab/-/issues/436084] 进行下载和安装。此补丁旨在解决特定的安全问题,确保系统的安全性和稳定性。安装前,请确保备份所有关键数据,并按照官方指南进行操作。安装后,进行全面测试以验证漏洞已被彻底修复,并确保系统其他功能正常运行。

Oracle Weblogic Server 未授权 代码注入(CVE-2024-21006)

内部编号

LDYVUL-2024-00520420

漏洞等级

高危

漏洞类型

代码注入

披露时间

2024-04-16

漏洞概述:

该漏洞是由于当weblogic 开启T3/IIOP协议时,攻击者可以向协议的监听端口发送恶意数据,进而在服务上执行任意代码,导致对关键数据的未授权访问或对所有 Oracle WebLogic Server 可访问数据的完全访问。

影响范围:

Oracle Weblogic Server=12.2.1.4.0

Oracle Weblogic Server=14.1.1.0.0

修复建议:

官方已经发布了安全更新,如有受影响的用户,建议立即更新到安全版本。

下载地址: 

https://www.oracle.com/middleware/technologies/weblogic-server-installers-downloads.html

Apache Struts2 未授权 文件上传限制不当

内部编号

LDYVUL-2023-00696314

漏洞等级

严重

漏洞类型

文件上传限制不当

披露时间

2023-12-07

漏洞概述:

Apache Struts2存在文件上传漏洞,该漏洞是由于文件上传逻辑存在缺陷,攻击者可以操纵文件上传参数来启用路径遍历,在某些情况下,这可能导致上传可用于执行远程代码执行的恶意文件。

影响范围:

2.0.0<=Apache Struts2<2.5.33

6.0.0<=Apache Struts2<6.3.0.2

修复建议:

针对此安全漏洞,官方已发布了一个修复补丁。请立即访问链接 [https://struts.apache.org/download.cgi#struts-ga] 进行下载和安装。此补丁旨在解决特定的安全问题,确保系统的安全性和稳定性。安装前,请确保备份所有关键数据,并按照官方指南进行操作。安装后,进行全面测试以验证漏洞已被彻底修复,并确保系统其他功能正常运行。

契约锁电子签章系统 upload 任意文件上传漏洞

内部编号

LDYVUL-2024-00268288

漏洞等级

严重

漏洞类型

文件上传限制不当

披露时间

2023-08-16

漏洞概述:

契约锁电子签章系统存在鉴权绕过导致的任意代码文件上传漏洞,攻击者可以利用该功能上传代码,并进行代码执行。

影响范围:

亘岩科技契约锁电子签章系统<2023.8

修复建议:

目前厂商已发布升级补丁以修复漏洞。

请根据厂商官网进行联系以获取补丁:

https://www.qiyuesuo.com/more/security/servicepack

PHP CGI 代码注入漏洞(CVE-2024-4577)

内部编号

LDYVUL-2024-00270053

漏洞等级

严重

漏洞类型

中和不当

披露时间

2024-06-07

漏洞概述:

PHP存在一个代码注入漏洞,当PHP以PHP-CGI模式运行在Window平台且使用了特定语系时,攻击者可构造恶意请求绕过 CVE-2012-1823 补丁,通过注入恶意的CGI模式命令参数,在服务上执行任意PHP代码。

影响范围:

8.3.0 <=PHP<8.3.8

8.2.0 <=PHP<8.2.20

8.1.0 <=PHP<8.1.29

修复建议:

官方已发布安全更新,建议升级至最新版本,其中低于8.x版本的PHP也受到漏洞影响,但官方已经不再进行维护,建议立即升级到安全版本。

安全版本:

PHP 8.3 >= 8.3.8

PHP 8.2 >= 8.2.20

PHP 8.1 >= 8.1.29

官方下载链接:

 https://www.php.net/downloads

泛微 E-Cology 未授权 SQL注入漏洞

内部编号

LDYVUL-2024-00268419

漏洞等级

严重

漏洞类型

中和不当

披露时间

2023-08-07

漏洞概述:

泛微E-Cology

CptDwrUtil.ifNewsCheckOutByCurrentUser.dwr 接口存在SQL注入漏洞,攻击者可以利用此漏洞获取服务器敏感信息。

修复建议:

泛微已经发布了漏洞修复补丁,建议用户尽快升级到最新版本,下载链接:

https://www.weaver.com.cn/cs/securityDownload.html#

金蝶云星空 GetServiceUri.common 反序列化漏洞

内部编号

LDYVUL-2023-00519871

漏洞等级

严重

漏洞类型

反序列化

披露时间

2023-06-17

漏洞概述:

金蝶云星空存在远程代码执行漏洞,该漏洞是由于金蝶云星空管理中心的通信层默认采用的是二进制数据格式,需要进行序列化与反序列化,在此通信过程中未做签名或校验,攻击者可以恶意修改传输的数据,导致执行任意代码执行。

影响范围:

6.0 <= 金蝶云星空 <6.2.1012.4
7.0.352.16 <= 金蝶云星空 < 7.7.0.202111
8.0.0.202205<= 金蝶云星空 < 8.1.0.20221110

修复建议:

官方现已提供 【星空卫士安全检测助手】,用户可下载工具进行检测,并参照修复建议进行修复,工具下载地址:https://vip.kingdee.com/knowledge/specialDetail/352491453127123200?category=528612109790002176&id=558389666802360320&productLineId=1&lang=zh-CN

Metabase /api/setup 未授权 反序列化 (CVE-2023-38646)

内部编号

LDYVUL-2023-00078973

漏洞等级

高危

漏洞类型

反序列化

披露时间

2023-07-24

漏洞概述:

Metabase是一个开源的数据分析和可视化工具,它可以帮助用户轻松地连接到各种数据源,包括数据库、云服务和API,然后使用直观的界面进行数据查询、分析和可视化。

Metabase 在 0.46.6.1 版本之前的开源版本和 1.46.6.1 版本之前的企业版本中存在远程代码执行漏洞,可导致攻击者在服务器上以运行 Metabase 服务器的权限执行任意代码。

影响范围:

Metabase 开源版<0.46.6.1

Metabase 企业版<1.46.6.1

修复建议:

官方已发布新版本中修复上述漏洞,受影响用户请尽快升级到安全版本。

漏洞修复版本:

Metabase open source >= 0.46.6.1

Metabase Enterprise >= 1.46.6.1

Metabase open source >= v0.45.4.1

Metabase Enterprise >= v1.45.4.1

Metabase open source >= v0.44.7.1

Metabase Enterprise >= v1.44.7.1

Metabase open source >= v0.43.7.2

Metabase Enterprise >= v1.43.7.2

下载链接:

https://www.metabase.com/start/oss/

Spring Framework 身份认证绕过漏洞(CVE-2023-20860)

内部编号

LDYVUL-2023-00080196

漏洞等级

高危

漏洞类型

身份认证缺陷

披露时间

2023-03-22

漏洞概述:

Spring Framework是spring 里面的一个基础开源框架,主要用于javaee的企业开发。

在Spring Security配置中使用 "**"作为mvcRequestMatcher的模式,会造成Spring Security和Spring MVC之间模式匹配的不匹配,并有可能出现安全绕过。漏洞编号:CVE-2024-20860,漏洞等级:高危。

影响范围:

6.0.0<=Vmware Spring Framework<=6.0.6

5.3.0<=Vmware Spring Framework<=5.3.25

修复建议:

厂商已发布补丁修复漏洞,用户请尽快更新至安全版本:

5.x 用户应升级到 5.3.26。

6.x 用户应升级到 6.0.7。

04

更多漏洞列表

漏洞云情报订阅用户可在漏洞云情报Web端(https://loudongyun.360.cn/)获取漏洞细节、完整POC和漏洞修复方案等完整信息。

目前,360 智能化攻防演练解决方案中的十余款产品已完成《攻防演练最新漏洞合集》中的漏洞验证评估,企业可以根据自身资产情况进行排查、补丁升级、防御策略优化等工作。其中:

\ | /

事前阶段,360本地安全大脑重保演练工作台可迅速组建保障团队,结合完善的流程组织以及历年沉淀的知识库进行模型优化、预案编排、定制工具预演习等,大幅提升运营效率和成效。360抗攻击能力评估系统(360 BAS)在迎接护网大考前以历年真题摸底,查漏补缺、加固防线。

360资产与漏洞检测管理系统、360信息资产安全统一管理平台等可提供资产梳理/攻击面分析服务;360网站云防护系统(磐云)、360网站云监测系统(云探)等可提供风险排查服务;360终端安全管理系统等提供安全体系加固服务,帮助政企单位摸清家底,强化防线。

\ | /

事中阶段,360本地安全大脑能够快速响应网络威胁,实现精准溯源,维护系统稳定和网络安全;360文件威胁分析系统(沙箱)、360高级持续性威胁预警系统(NDR一体机企业版)等多款产品提供态威胁态势监测及应急响应服务,帮助政企单位智能决策-快速响应-精准溯源。

\ | /

事后阶段,360本地安全大脑完整记录了重保演练全流程,依据相关信息可进行重保演练整体复盘、问题发现整改、打法策略更新、预案配置改进并快速输出总结报告、提供了全面的复盘和总结服务,帮助政企单位全面回顾和总结技战法经验,沉淀技战法。

05

漏洞情报订阅

实时漏洞情报推送

请关注360漏洞云公众号

(免费推送漏洞情报)

演练期间漏洞云7x24h在线支援,如需定向支持,获取专属漏洞情报服务,欢迎联系技术专家咨询!

咨询邮箱:[email protected]

在线沟通⬇


文章来源: https://mp.weixin.qq.com/s?__biz=MzA4MTg0MDQ4Nw==&mid=2247572465&idx=1&sn=4700b25b79ff92902644872cf1c687ab&chksm=9f8d4bf9a8fac2ef8b33453eae5abcc5cf300d951051a303b7c00b90e5f41b5487d0bb4a59b4&scene=58&subscene=0#rd
如有侵权请联系:admin#unsafe.sh