Ubuntu Security Notice USN-6731-1
2024-4-16 00:25:14 Author: packetstormsecurity.com(查看原文) 阅读量:4 收藏

Ubuntu Security Notice USN-6731-1
April 15, 2024

yard vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 23.10
- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS (Available with Ubuntu Pro)
- Ubuntu 16.04 LTS (Available with Ubuntu Pro)


Several security issues were fixed in yard.

Software Description:
- yard: Ruby documentation tool


It was discovered that YARD before 0.9.11 does not block relative paths
with an initial ../ sequence, which allows attackers to conduct
directory traversal attacks and read arbitrary files. This issue only
affected Ubuntu 16.04 LTS. (CVE-2017-17042)

It was discovered that yard before 0.9.20 is affected by a path
traversal vulnerability, allowing HTTP requests to access arbitrary
files under certain conditions. This issue only affected Ubuntu 18.04
LTS. (CVE-2019-1020001)

Aviv Keller discovered that the "frames.html" file within the Yard
Doc's generated documentation is vulnerable to Cross-Site Scripting
(XSS) attacks due to inadequate sanitization of user input within the
JavaScript segment of the "frames.erb" template file. (CVE-2024-27285)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 23.10:
yard 0.9.28-2ubuntu0.1

Ubuntu 22.04 LTS:
yard 0.9.26-1ubuntu0.1

Ubuntu 20.04 LTS:
yard 0.9.24-1+deb11u1build0.20.04.1

Ubuntu 18.04 LTS (Available with Ubuntu Pro):
yard 0.9.12-2ubuntu0.1~esm1

Ubuntu 16.04 LTS (Available with Ubuntu Pro):

In general, a standard system update will make all the necessary changes.

CVE-2017-17042, CVE-2019-1020001, CVE-2024-27285

Package Information:

文章来源: https://packetstormsecurity.com/files/178063/USN-6731-1.txt