Ubuntu Security Notice USN-6653-1
2024-2-26 21:53:2 Author: packetstormsecurity.com(查看原文) 阅读量:4 收藏

==========================================================================
Ubuntu Security Notice USN-6653-1
February 23, 2024

linux, linux-azure, linux-azure-5.15, linux-azure-fde, linux-gcp,
linux-gcp-5.15, linux-gkeop, linux-gkeop-5.15, linux-hwe-5.15, linux-ibm,
linux-ibm-5.15, linux-intel-iotg, linux-intel-iotg-5.15, linux-kvm,
linux-lowlatency-hwe-5.15, linux-nvidia, linux-oracle, linux-oracle-5.15,
linux-raspi vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS

Summary:

Several security issues were fixed in the Linux kernel.

Software Description:
- linux: Linux kernel
- linux-azure: Linux kernel for Microsoft Azure Cloud systems
- linux-azure-fde: Linux kernel for Microsoft Azure CVM cloud systems
- linux-gcp: Linux kernel for Google Cloud Platform (GCP) systems
- linux-gkeop: Linux kernel for Google Container Engine (GKE) systems
- linux-ibm: Linux kernel for IBM cloud systems
- linux-intel-iotg: Linux kernel for Intel IoT platforms
- linux-kvm: Linux kernel for cloud environments
- linux-nvidia: Linux kernel for NVIDIA systems
- linux-oracle: Linux kernel for Oracle Cloud systems
- linux-raspi: Linux kernel for Raspberry Pi systems
- linux-azure-5.15: Linux kernel for Microsoft Azure cloud systems
- linux-gcp-5.15: Linux kernel for Google Cloud Platform (GCP) systems
- linux-gkeop-5.15: Linux kernel for Google Container Engine (GKE) systems
- linux-hwe-5.15: Linux hardware enablement (HWE) kernel
- linux-ibm-5.15: Linux kernel for IBM cloud systems
- linux-intel-iotg-5.15: Linux kernel for Intel IoT platforms
- linux-lowlatency-hwe-5.15: Linux low latency kernel
- linux-oracle-5.15: Linux kernel for Oracle Cloud systems

Details:

It was discovered that a race condition existed in the ATM (Asynchronous
Transfer Mode) subsystem of the Linux kernel, leading to a use-after-free
vulnerability. A local attacker could use this to cause a denial of service
(system crash) or possibly execute arbitrary code. (CVE-2023-51780)

It was discovered that a race condition existed in the AppleTalk networking
subsystem of the Linux kernel, leading to a use-after-free vulnerability. A
local attacker could use this to cause a denial of service (system crash)
or possibly execute arbitrary code. (CVE-2023-51781)

Zhenghan Wang discovered that the generic ID allocator implementation in
the Linux kernel did not properly check for null bitmap when releasing IDs.
A local attacker could use this to cause a denial of service (system
crash). (CVE-2023-6915)

Robert Morris discovered that the CIFS network file system implementation
in the Linux kernel did not properly validate certain server commands
fields, leading to an out-of-bounds read vulnerability. An attacker could
use this to cause a denial of service (system crash) or possibly expose
sensitive information. (CVE-2024-0565)

Jann Horn discovered that the TLS subsystem in the Linux kernel did not
properly handle spliced messages, leading to an out-of-bounds write
vulnerability. A local attacker could use this to cause a denial of service
(system crash) or possibly execute arbitrary code. (CVE-2024-0646)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 22.04 LTS:
linux-image-5.15.0-1037-gkeop 5.15.0-1037.43
linux-image-5.15.0-1045-nvidia 5.15.0-1045.45
linux-image-5.15.0-1045-nvidia-lowlatency 5.15.0-1045.45
linux-image-5.15.0-1047-ibm 5.15.0-1047.50
linux-image-5.15.0-1047-raspi 5.15.0-1047.50
linux-image-5.15.0-1049-intel-iotg 5.15.0-1049.55
linux-image-5.15.0-1051-kvm 5.15.0-1051.56
linux-image-5.15.0-1052-gcp 5.15.0-1052.60
linux-image-5.15.0-1052-oracle 5.15.0-1052.58
linux-image-5.15.0-1057-azure 5.15.0-1057.65
linux-image-5.15.0-1057-azure-fde 5.15.0-1057.65.1
linux-image-5.15.0-97-generic 5.15.0-97.107
linux-image-5.15.0-97-generic-64k 5.15.0-97.107
linux-image-5.15.0-97-generic-lpae 5.15.0-97.107
linux-image-azure-fde-lts-22.04 5.15.0.1057.65.35
linux-image-azure-lts-22.04 5.15.0.1057.53
linux-image-gcp-lts-22.04 5.15.0.1052.48
linux-image-generic 5.15.0.97.92
linux-image-generic-64k 5.15.0.97.92
linux-image-generic-lpae 5.15.0.97.92
linux-image-gkeop 5.15.0.1037.36
linux-image-gkeop-5.15 5.15.0.1037.36
linux-image-ibm 5.15.0.1047.43
linux-image-intel-iotg 5.15.0.1049.49
linux-image-kvm 5.15.0.1051.47
linux-image-nvidia 5.15.0.1045.45
linux-image-nvidia-lowlatency 5.15.0.1045.45
linux-image-oracle 5.15.0.1052.47
linux-image-oracle-lts-22.04 5.15.0.1052.47
linux-image-raspi 5.15.0.1047.45
linux-image-raspi-nolpae 5.15.0.1047.45
linux-image-virtual 5.15.0.97.92

Ubuntu 20.04 LTS:
linux-image-5.15.0-1037-gkeop 5.15.0-1037.43~20.04.1
linux-image-5.15.0-1047-ibm 5.15.0-1047.50~20.04.1
linux-image-5.15.0-1049-intel-iotg 5.15.0-1049.55~20.04.1
linux-image-5.15.0-1052-gcp 5.15.0-1052.60~20.04.1
linux-image-5.15.0-1052-oracle 5.15.0-1052.58~20.04.1
linux-image-5.15.0-1057-azure 5.15.0-1057.65~20.04.1
linux-image-5.15.0-97-generic 5.15.0-97.107~20.04.1
linux-image-5.15.0-97-generic-64k 5.15.0-97.107~20.04.1
linux-image-5.15.0-97-generic-lpae 5.15.0-97.107~20.04.1
linux-image-5.15.0-97-lowlatency 5.15.0-97.107~20.04.1
linux-image-5.15.0-97-lowlatency-64k 5.15.0-97.107~20.04.1
linux-image-azure 5.15.0.1057.65~20.04.46
linux-image-azure-cvm 5.15.0.1057.65~20.04.46
linux-image-gcp 5.15.0.1052.60~20.04.1
linux-image-generic-64k-hwe-20.04 5.15.0.97.107~20.04.51
linux-image-generic-hwe-20.04 5.15.0.97.107~20.04.51
linux-image-generic-lpae-hwe-20.04 5.15.0.97.107~20.04.51
linux-image-gkeop-5.15 5.15.0.1037.43~20.04.33
linux-image-ibm 5.15.0.1047.50~20.04.19
linux-image-intel 5.15.0.1049.55~20.04.39
linux-image-intel-iotg 5.15.0.1049.55~20.04.39
linux-image-lowlatency-64k-hwe-20.04 5.15.0.97.107~20.04.48
linux-image-lowlatency-hwe-20.04 5.15.0.97.107~20.04.48
linux-image-oem-20.04 5.15.0.97.107~20.04.51
linux-image-oem-20.04b 5.15.0.97.107~20.04.51
linux-image-oem-20.04c 5.15.0.97.107~20.04.51
linux-image-oem-20.04d 5.15.0.97.107~20.04.51
linux-image-oracle 5.15.0.1052.58~20.04.1
linux-image-virtual-hwe-20.04 5.15.0.97.107~20.04.51

After a standard system update you need to reboot your computer to make
all the necessary changes.

ATTENTION: Due to an unavoidable ABI change the kernel updates have
been given a new version number, which requires you to recompile and
reinstall all third party kernel modules you might have installed.
Unless you manually uninstalled the standard kernel metapackages
(e.g. linux-generic, linux-generic-lts-RELEASE, linux-virtual,
linux-powerpc), a standard system upgrade will automatically perform
this as well.

References:
https://ubuntu.com/security/notices/USN-6653-1
CVE-2023-51780, CVE-2023-51781, CVE-2023-6915, CVE-2024-0565,
CVE-2024-0646

Package Information:
https://launchpad.net/ubuntu/+source/linux/5.15.0-97.107
https://launchpad.net/ubuntu/+source/linux-azure/5.15.0-1057.65
https://launchpad.net/ubuntu/+source/linux-azure-fde/5.15.0-1057.65.1
https://launchpad.net/ubuntu/+source/linux-gcp/5.15.0-1052.60
https://launchpad.net/ubuntu/+source/linux-gkeop/5.15.0-1037.43
https://launchpad.net/ubuntu/+source/linux-ibm/5.15.0-1047.50
https://launchpad.net/ubuntu/+source/linux-intel-iotg/5.15.0-1049.55
https://launchpad.net/ubuntu/+source/linux-kvm/5.15.0-1051.56
https://launchpad.net/ubuntu/+source/linux-nvidia/5.15.0-1045.45
https://launchpad.net/ubuntu/+source/linux-oracle/5.15.0-1052.58
https://launchpad.net/ubuntu/+source/linux-raspi/5.15.0-1047.50
https://launchpad.net/ubuntu/+source/linux-azure-5.15/5.15.0-1057.65~20.04.1
https://launchpad.net/ubuntu/+source/linux-gcp-5.15/5.15.0-1052.60~20.04.1
https://launchpad.net/ubuntu/+source/linux-gkeop-5.15/5.15.0-1037.43~20.04.1
https://launchpad.net/ubuntu/+source/linux-hwe-5.15/5.15.0-97.107~20.04.1
https://launchpad.net/ubuntu/+source/linux-ibm-5.15/5.15.0-1047.50~20.04.1

https://launchpad.net/ubuntu/+source/linux-intel-iotg-5.15/5.15.0-1049.55~20.04.1

https://launchpad.net/ubuntu/+source/linux-lowlatency-hwe-5.15/5.15.0-97.107~20.04.1

https://launchpad.net/ubuntu/+source/linux-oracle-5.15/5.15.0-1052.58~20.04.1


文章来源: https://packetstormsecurity.com/files/177296/USN-6653-1.txt
如有侵权请联系:admin#unsafe.sh